Online repository of useful commands for CCIE Data Center study

vrf context management
ip name-server 192.168.0.1
ip route 0.0.0.0/0 192.168.0.1
ntp peer nl.pool.ntp.org use-vrf management
ntp source 192.168.0.83
cli alias name commit copy run start vdc-all
cli alias name wr copy run start
cli alias name top show process cpu

spanning-tree mode mst
spanning-tree mst 0 priority 4096
spanning-tree mst configuration
name CCIE

feature vrrp
feature telnet
feature ospf
feature pbr
feature private-vlan
feature interface-vlan
feature vpc
feature vtp

spanning-tree port type network

TITB(config-if)# 2012 Jul 15 16:42:36 TITB %STP-2-BRIDGE_ASSURANCE_BLOCK: Bridge Assurance blocking port Ethernet2/5 MST0000.
2012 Jul 15 16:42:58 TITB %STP-2-BRIDGE_ASSURANCE_UNBLOCK: Bridge Assurance unblocking port Ethernet2/5 MST0000.

TITA# show spanning-tree

MST0000
Spanning tree enabled protocol mstp
Root ID Priority 4096
Address 000c.2937.3afb
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4096 (priority 4096 sys-id-ext 0)
Address 000c.2937.3afb
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————

Eth2/2 Desg BKN*20000 128.258 Network P2p *BA_Inc
Eth2/4 Desg BKN*20000 128.260 Network P2p *BA_Inc

 

TITC(config-if)# spanning-tree port type edge trunk
Warning: Edge port type (portfast) should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc… to this
interface when edge port type (portfast) is enabled, can cause temporary bridging loops.
Use with CAUTION

TITC(config-if)# spanning-tree port type edge
Warning: Edge port type (portfast) should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc… to this
interface when edge port type (portfast) is enabled, can cause temporary bridging loops.
Use with CAUTION

Edge Port Type (Portfast) has been configured on Ethernet2/8 but will only
have effect when the interface is in a non-trunking mode.

 

interface Ethernet2/8
switchport
switchport mode trunk
spanning-tree port type edge
no shutdown

TITA# show spanning-tree detail

MST0000 is executing the mstp compatible Spanning Tree protocol
Bridge Identifier has priority 4096, sysid 0, address 000c.2937.3afb
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 3 last change occurred 2:45:02 ago
from Ethernet2/2

#disable adapter

TITA# show spanning-tree detail

MST0000 is executing the mstp compatible Spanning Tree protocol
Bridge Identifier has priority 4096, sysid 0, address 000c.2937.3afb
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 4 last change occurred 0:01:05 ago
from Ethernet2/4

TITC(config-if)# show spanning-tree

MST0000
Spanning tree enabled protocol mstp
Root ID Priority 4096
Address 000c.2937.3afb
Cost 0
Port 260 (Ethernet2/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768 (priority 32768 sys-id-ext 0)
Address 000c.2982.2e7b
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Eth2/4 Root FWD 20000 128.260 Network P2p
Eth2/6 Desg FWD 20000 128.262 Network P2p
Eth2/8 Desg FWD 20000 128.264 P2p

TITC(config-if)# spanning-tree port type edge trunk
Warning: Edge port type (portfast) should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc… to this
interface when edge port type (portfast) is enabled, can cause temporary bridging loops.
Use with CAUTION

interface Ethernet2/8
switchport
switchport mode trunk
spanning-tree port type edge trunk
no shutdown

 

 

TITC(config-if)# show spanning-tree

MST0000
Spanning tree enabled protocol mstp
Root ID Priority 4096
Address 000c.2937.3afb
Cost 0
Port 260 (Ethernet2/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768 (priority 32768 sys-id-ext 0)
Address 000c.2982.2e7b
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Eth2/4 Root FWD 20000 128.260 Network P2p
Eth2/6 Desg FWD 20000 128.262 Network P2p
Eth2/8 Desg FWD 20000 128.264 Edge P2p

TITA# show spanning-tree detail

MST0000 is executing the mstp compatible Spanning Tree protocol
Bridge Identifier has priority 4096, sysid 0, address 000c.2937.3afb
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 5 last change occurred 0:02:11 ago

#disable adapter

TITA# show spanning-tree detail

MST0000 is executing the mstp compatible Spanning Tree protocol
Bridge Identifier has priority 4096, sysid 0, address 000c.2937.3afb
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 5 last change occurred 0:04:04 ago
from Ethernet2/4

 

Published by

Michel van Kessel

Specialist in Data Center Infrastructure Designs and Cloud Designs. CCIE Data Center #44197 #CiscoChampion

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s